PDA

View Full Version : 2005 40K weird trouble, multiple warning lights, stalling


csasu
09-15-2010, 11:48 PM
Hi folks,

I have an '05 Sprinter with about 40K miles giving me some weird trouble. The events that have occurred are all a little different, and I'm hoping they're related:

(1) ABS, ASR, and ESP lights all came on when the vehicle was at a standstill.
(2) Engine stalled seconds after starting. ABS, ASR, ESP, and battery lights came on.

After 1 and 2 happened, I went to my dealer and the code showed the brake light switch problem. Replaced that. No codes related to stalling. Then:

(3) Seat belt warning light came on while driving, despite seat belt being fastened.
(4) Loud rhythmic groaning/vibration sound during braking at high speed, coming from front of vehicle.
(5) During slow coasting, sudden slew of multiple warning lights (including seat belt) came on for about a second, then gone! Brake pedal softened. Ventilation fan stopped. Then with a little acceleration everything came back.

Much appreciation for any thoughts about what this could be.

Confused in California :)

showkey
09-16-2010, 01:34 AM
TOTAL Wild guess: Low battery voltage...............system voltage dropping below the allowable limits and all sorts of codes and symptoms may appear

original battery with a bad cell going bad???
corroded loose battery cables???
just an old battery with a strained alternator???

ever have a slow crank?

csasu
09-17-2010, 07:01 AM
Thanks for the thoughts showkey!

I checked the voltage on the battery, and at all the terminals in the fuse box under the hood - all ok. Never had a slow crank. Other tests I can do?

Cheers

Aqua Puttana
09-17-2010, 11:51 AM
Another guess.

A marginal common ground related to corrosion or loose connections? There was recently a post about how cleaning the ground connections cured some other problems. Good luck. vic