Sprinter-Forum    
 

Go Back   Sprinter-Forum > T1N Sprinters > T1N Talk

T1N Talk General Discussions related to T1N Sprinters.


Reply
 
Thread Tools Display Modes
Old 01-12-2013, 03:21 PM   #1
maxzoom
 
Join Date: Mar 2008
Posts: 150
Thanks: 55
Thanked 13 Times in 8 Posts
Default Headlights not working

""Quote:
Originally Posted by JRK96
Check the plastic electrical connectors to the bulb.
I found a damaged / cracked connector housing on one of my headlights - to be the root cause of rapid bulb failure on one side. Replaced both sides with an after market connector available at the Autoparts store for about $7.00. ""


I do not have DRL on my 2005 or 2006.

Till now the headlights have been no problem.

I had one lowbeam headlight out on my 2005 driver's side. The H7 bulb was obviously burnt out. I replaced it with a new H7 bulb but the lowbeam would not go on. I checked the connector which looks fine. I wiggled and wiggled it and finally the H7 lowbeam went on. So I am going to order a 2 of those connectors. Are those connectors easy to replace and install? Looks like you just have to cut the two wires to the connector and splice them into the new connector. Right?

But now a bigger headlight problem on the passenger side just came up for the first time. The passenger lowbeam and high beam headlamps were working fine. Just that little white bulb was out for a long time. I call it the parking light bulb. In the 2005 Sprinter Parts CD I think they call it Front Position Lamp W5W-12V 5W. Anyway I was about to replace the bulb and it went on when I started to remove it. So I didn't replace it... i guess just a loose connection.

I put back on the cover of the passenger side and turned on the headlights. The passenger lowbeam did not work! I checked the low beam bulb it looked fine but replaced it anyway with a new one. Low beam still did not work. I wiggled and wiggled the connector but still the low beam passenger side will not turn on.

What is going on? That parking light front position light went out again. Sometimes you can get by with just the Front Position lamp (the police will not stop you it just looks like a dim headlamp). Any help or ideas please. It is dark season now. And the police will stop a vehicle with only one headlight working.
__________________
2005 Dodge/Sprinter 2500 140" Wheel Base 10 passenger 210,000 miles
2006 Dodge/Sprinter 2500 118" Wheel Base 8 passenger 44,000 miles
__________________
2005 Dodge/Sprinter 2500 140" Wheel Base 10 passenger 236,000 miles
2006 Dodge/Sprinter 2500 118" Wheel Base 8 passenger 45,000 miles

Last edited by maxzoom; 01-12-2013 at 03:25 PM.
maxzoom is offline   Reply With Quote
Old 01-12-2013, 08:17 PM   #2
autostaretx
Erratic Member
 
autostaretx's Avatar
 
Join Date: Sep 2006
Location: Seattle
Posts: 5,335
Thanks: 774
Thanked 1,764 Times in 1,374 Posts
Default Re: Headlights not working

Unplug the connector, and verify that each pin is doing what it should:
That the ground pin (brown wire) has a good connection to the Sprinter frame (i.e. very close to zero ohms on an ohmmeter... not infinite. 2 ohms or higher is too much).
That each of the power pins are being driven (12v) when that lamp circuit is on.

Refer to wiring section 8W from the 2003 or 2006 service manuals, available here: http://aie-services-2.net/Sprinter/

good luck
--dick
__________________
2005 T1N 118" Freightliner 2500 Passenger Wagon (2.7L, 15" tires, standard (short) roof)
autostaretx is offline   Reply With Quote
The Following 2 Users Say Thank You to autostaretx For This Useful Post:
angolaron (01-13-2013), maxzoom (01-13-2013)
Old 01-13-2013, 11:56 AM   #3
Amboman
Hard Yakker 316CDI
 
Amboman's Avatar
 
Join Date: May 2011
Location: Australia 3000
Posts: 746
Thanks: 46
Thanked 158 Times in 119 Posts
Default Re: Headlights not working

Sounds like a bad earth
Amboman is offline   Reply With Quote
Old 01-13-2013, 03:13 PM   #4
maxzoom
 
Join Date: Mar 2008
Posts: 150
Thanks: 55
Thanked 13 Times in 8 Posts
Default Re: Headlights not working

Quote:
Originally Posted by Amboman View Post
Sounds like a bad earth
No I don't think it is as bad as that. Did you ever read "The Good Earth" by Pearl S.Buck. We read that book in a High School class way back when. It was a good book.

Anyway I am just having some dumb luck. Or like that Led Zepplin song "Good Times Bad Times" And still working on "Don't Make Little Problems into Big Problems".

The bottom line is I had a stroke 3 years ago. The stroke (brain attack) hit the left part of my brain. I have Aphasia; can not communicate, understand, etc as well. So what I'm trying to say is give me some slack and understanding. But anyway thank God I am still alive and can walk, talk, and a good driver IMHO (no tickets or warnings in the last 5 or so years).
__________________
2005 Dodge/Sprinter 2500 140" Wheel Base 10 passenger 236,000 miles
2006 Dodge/Sprinter 2500 118" Wheel Base 8 passenger 45,000 miles

Last edited by maxzoom; 01-14-2013 at 01:49 PM. Reason: spelling and communication
maxzoom is offline   Reply With Quote
Old 01-13-2013, 04:46 PM   #5
autostaretx
Erratic Member
 
autostaretx's Avatar
 
Join Date: Sep 2006
Location: Seattle
Posts: 5,335
Thanks: 774
Thanked 1,764 Times in 1,374 Posts
Default Re: Headlights not working

"bad earth" is the Queen's English for "bad ground connection" ... which is what my "test the brown wire" was talking about.

..and your headlight's symptoms are fairly typical for that kind of fault.

--dick
__________________
2005 T1N 118" Freightliner 2500 Passenger Wagon (2.7L, 15" tires, standard (short) roof)
autostaretx is offline   Reply With Quote
The Following User Says Thank You to autostaretx For This Useful Post:
maxzoom (01-14-2013)
Old 01-14-2013, 11:30 AM   #6
JAM
 
JAM's Avatar
 
Join Date: Oct 2011
Location: Michigan
Posts: 240
Thanks: 25
Thanked 39 Times in 29 Posts
Default Re: Headlights not working

Sorry to hear about your stroke and yes it is a great thing your still alive and doing good.
My headlights did the same thing last year. My problem was a burned connector and the stake on that goes to the lights were opened up a bit. Try squeezing them tight with pliers or strippers and make sure they are snug. I also used electrical anti sieze gel on them to stop any more corrosion. No problems so far.
__________________
2004 regular roof 2500 140wb
253k miles and counting
JAM is offline   Reply With Quote
The Following User Says Thank You to JAM For This Useful Post:
maxzoom (01-14-2013)
Old 01-14-2013, 01:14 PM   #7
pgr
 
Join Date: Sep 2006
Location: Far left of center
Posts: 1,621
Thanks: 393
Thanked 266 Times in 196 Posts
Default Re: Headlights not working

I had to replace the connector on one side as it melted from the heat of the halogen bulb. I decided to just replace both sides with ceramic ones I discovered online (no link, sorry) they were only about $5 each as I recall and no more problems! I also removed the 3 daytime running light fuses so they do not burn out as often (the license plate bulb is still always on however).
pgr is offline   Reply With Quote
Old 01-14-2013, 01:37 PM   #8
maxzoom
 
Join Date: Mar 2008
Posts: 150
Thanks: 55
Thanked 13 Times in 8 Posts
Default Re: Headlights not working

Quote:
Originally Posted by autostaretx View Post
"bad earth" is the Queen's English for "bad ground connection" ... which is what my "test the brown wire" was talking about.

..and your headlight's symptoms are fairly typical for that kind of fault.

--dick
Thanks for explaining to me about "bad earth". That's the first time I heard that phrase. I thought Amboman wasn't talking about cars and took that phrase personally.
__________________
2005 Dodge/Sprinter 2500 140" Wheel Base 10 passenger 236,000 miles
2006 Dodge/Sprinter 2500 118" Wheel Base 8 passenger 45,000 miles
maxzoom is offline   Reply With Quote
Old 01-15-2013, 11:40 PM   #9
kjg912
2004 T1N 2500
 
Join Date: Dec 2012
Location: Albuquerque, NM
Posts: 16
Thanks: 11
Thanked 8 Times in 4 Posts
Default Re: Headlights not working

I also have an issue with my 2004 Sprinter passenger side headlight - it works when started but not when I use the headlight switch! The brights work either way, but the dim does not! Is there a different fuse that the power goes through when the switch is turned on or is perhaps the headlight switch faulty?
kjg912 is online now   Reply With Quote
Old 01-15-2013, 11:56 PM   #10
kjg912
2004 T1N 2500
 
Join Date: Dec 2012
Location: Albuquerque, NM
Posts: 16
Thanks: 11
Thanked 8 Times in 4 Posts
Default Re: Headlights not working

I found a previous thread on this subject/problem, I will check fuses as this is indeed the starting point! Cheers!
kjg912 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 04:43 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © 2006 - 2012, Sprinter-Source.com